The most reliable way to create sites which always retain their layout when viewed in all browsers is to use “inline CSS layout”—often called “box-model”. Using box-model ensures that if text expands on the page, the container for that text will expand to fit and it will push down the content of the page which is beneath it. Another common reason for using this method is so you can create a footer item at the bottom of the page which will move down automatically if the content above it expands, and also to have header and footer bars which fill the width of the browser window.

This article explains how to create a simple box-model layout. It's worth stressing, however, that working in box-model is very different to working with the default Freeway layout method. Although at first it may seem quite unintuitive, once you become familiar with the basic concepts you’ll find that it’s essentially just a different way to build web pages and the process will soon become clear.

In this brief tutorial we will work through the steps of how the sample Freeway file you downloaded was created. Hopefully, once you have followed the steps here you will be inspired to experiment with your own layouts.

Working in box-model means that you need to create items in a very specific hierarchy, so it’s advisable to plan out your layout before you start. Unlike Freeway’s default layout method, box-model layouts can be difficult to change “on the fly”, to the point that it is often simpler to start again if you want to change the basic layout structure of the page.

Creating a file and setting up the page

First thing to do is to create a new Freeway file. Make the width of the page slightly larger than the page area you want—so if you want an 880px width page (like the sample file), make the page 900px wide. The reason for doing this is so you can see the different levels of nested items on the Freeway page, which makes it easier to see background colors or images applied to parent items and also to make it easy to select a specific nested item or its parent container.

You don’t need to worry about the height of the page as this increases automatically when the content increases).

Set the HTML standard to **XHTML 1.0 Transitional** in the **Default HTML** popup or the **Output Settings** tab of the Inspector. Note, however, that it should work fine even if the file is set to the default HTML 4.01 Transitional.

For most box-model layouts the **Align** setting for the page should be set to **None** in the Inspector, especially if the layout uses a header bar and/or footer bar which stretches across the page to fill the width of the browser window.
I prefer to work with the option for “undefined” height switched on—so go to the Freeway 5 Pro menu, choose Preferences, go to the Layout tab and change the popup to Ask (you will see why later).

Finally, make sure you have the CSS Layout button switched on (so it displays in blue on Freeway’s tool bar).

Setting up the hierarchy of nested items

1. Make sure you have the Select tool selected on Freeway’s tool bar and double-click in the blank page area so you can see the flashing text cursor appear in the top left corner.
2. Go to Insert>HTML item.

This places an HTML item of the default 100px square in the top left of the page. This item is effectively the browser background (rather than the page background) and it will be the container item for all the items on the page.

3. With the HTML item selected, enter 100% in the Width field of the Inspector.

By using 100% for the Width value, this item will always fill the width of the browser window whatever size it is made.

Note that you can use percentage or pixel widths, but for this item to fill the width of the browser you should always use 100%.

Note that 100% width will make the item fit the page area on your Freeway page—however, when previewed in a browser this will actually stretch to the full width of the browser window.

4. Double-click inside the HTML item (so the flashing text cursor appears in the top left of the item) and go to Insert>HTML item three times so you can see three new items stacked underneath each other.

Note that by double-clicking inside an HTML item and then inserting items using the Insert menu you will be placing these new items “inline” (rather than just making them standard “child” items in the normal parent/child relationship). For box-model to work correctly items must be used inline.

5. Deselect all the items by clicking on a blank area of the page (or the pasteboard). This will prompt an alert asking you if you want to set the parent item (ie, the item you inserted the three new HTML items into) to have an “undefined height”. Click OK.

This alert displays because the Layout popup is set to “Ask” in Freeway’s preferences. This item now has an undefined height, so its height will automatically resize when the content of the item increases or decreases. On the Freeway page you will see the parent item’s height has automatically changed to fit the height of the three new HTML items.
6. Select the uppermost the three HTML items you just inserted then go to the Inspector and click once on the **Width** button (to the left of the **Width** value field).

Clicking once on the Width button will make the item fill the width of its container (parent) item. This item, which is eventually going to be our header bar, will now fill the width of the item inserted in Step 2 which had its Width value set to 100% (so this means that the header bar is now set to fill the width of the browser window).

7. Select the lower of the three HTML items you inserted and click once on the **Width** button in the Inspector.

This item is going to be the footer bar so, like the header bar, this is now set to fill the width of the browser window.

8. Select the middle item of the three HTML items you inserted and enter a **Width** value of 880 pixels in the Inspector. With the item still selected, click on the **Margin** popup in the Inspector, choose Custom then check the **Center Horizontally (non-floating only)** option and click **OK**.

This HTML item—which will eventually be the main content area of the page—will now be centred horizontally of the Freeway page and, when the page is previewed in a browser later, it will be centered horizontally in the browser window.

### Naming the nested items

At this stage it’s a good idea to give names to the items on your page to help you identify which item is which. As the structure of nested items grows on your box-model layout can be difficult to keep track of where you are in the hierarchy, so it is good practice to give each item a recognizable name rather than Freeway’s default names.

1. Click on the header bar of the Site Panel to toggle the view from **Site** mode to **Page** mode.

This will now show you a list of items on the page, and it also displays the parent/child relationship of the items. Items which are displayed indented one level from the left indicates that they are child items of the item which isn’t indented immediately above them. Each level of nesting will display as an additional level of indent in the Site Panel list.

2. Alt-click the top item in the list to highlight its name and enter “browserbackground” (without the quotes). Change the names of the next three items to “headerbar”, “pagecontent” and “footerbar” respectively.

### Applying Clear attributes to the items

One major difference with working in box-model is that you need to use “Clear” and “Float” attributes on the items to control how they will appear in the layout. We will be using Float attributes later, but for now we need to set the Clear
attribute to Both for all the items we’ve used so far to ensure that each inline item appears on a line of its own rather than alongside each other.

1. Select each item in the Site Panel list in turn, click on the Clear popup in the Inspector and choose Both.

**Applying colors to the browser background and nested items**

At the moment the layout on the Freeway page is just a set of nested items, so it’s difficult to understand how they will interact with each other without previewing the page in a browser. However, we first need to apply colors to each of the items so they can be identified in the browser.

1. Select the “browserbackground” item in the Site Panel list, click on the Color popup in the Inspector and choose Yellow.
2. Select the “headerbar” and “footerbar” items one at a time and give them a color of Red.
3. Select the “pagecontent” item and give it a color of White.
4. Preview the file in a browser.

You can now test the structure of the page by resizing the browser window to see that the header and footer bars stretch across the full width of the browser window whatever size it is made and the white pagecontent item is always centered.

Note that the browser background color either side of the white pagecontent area is yellow. Unlike standard Freeway layout (where you choose the browser background color in the Color popup in the Paintbrush tab of the Inspector), in box-model the first item inserted inline on the page is usually the browser background. Once the pagecontent item has content used inside it (so that the content is always longer than the height of the browser window) the footerbar will always appear at the very bottom of the page. If the content of the page is shorter than the height of the browser window you may still want to use the Color popup in the Paintbrush tab of the Inspector to match the color used in the browserbackground item.

**Inserting inline column items inside another item using Float attributes**

Before using text on the page, we need to add two inline items inside the pagecontent item to be used as tint panels for text.

1. Select the “pagecontent” item, click on the Padding popup in the Inspector and choose 10px.

Doing this means that any new inline items will not butt up against the outer margins of the “pagecontent” item.
2. Double-click inside the pagecontent item (so the flashing text cursor displays) and go to **Insert>HTML** item twice.

3. Select the top item (this will prompt Freeway to ask you to give the pagecontent item an undefined height—click **OK**), click on the **Float** popup, choose **Right**, click on the **Clear** popup and choose **Right**.

4. Now select the other new item and give it a **Float** and **Clear** of **Left**.

Floats and Clears are very important in box-model and many people are confused about what they do. Using Clear means that no other item can move alongside (in the direction of the specific attribute used) and Float gives horizontal alignment to a child item within its parent.

5. It's now a good idea to name the two new items, so Alt-click on the name of the items in the Site Panel list and rename them “rhpanel” and “lhpanel” respectively.

6. Select the “lhpanel” item on the page, go to the Paintbrush tab of the Inspector, open the **Graphic Effects** panel and the click on the **Background** and **Border** buttons. Open the **Border** and **Background** panels below, choose **Black** for the border color then use a light grey color (perhaps Silver from the Crayons tab of Freeway's Color Picker) for the background color.

7. Repeat the process in Step 6 for the “rhpanel” item, using **Black** for the Border and a pale green for the **Background**.

8. Resize the widths of the “lhpanel” and “rhpanel” items so they look like the items in the screenshot below.

9. Select the “pagecontent” item, click on the **Overflow** popup in the Inspector and choose **Hidden**.

The reason for needing to choose the Overflow as Hidden is specific to the way that inline box-model works with HTML (and is a little beyond the brief of this basic tutorial)—but if you don’t set it to Hidden, the colour fill won’t be seen. You can leave all the other items as Overflow = Visible, which is the default.

**Adding text inside the nested items**

To make the tutorial file look more like a real web page, let’s add some text inside the relevant items.

1. Double-click on the “headerbar” item and enter the words “Header Bar” (without the quotes).

2. Select the text and style it using Verdana 36px and click on the center align button in the Inspector.

Because we switched on the option in Freeway’s preferences whenever you add anything (such as another HTML item, a
graphic item or text) inside a nested item you will always be prompted to give the item an undefined height as soon as you click away. This method helps to remind you to do it.

3. Click on a blank area of the page or pasteboard to deselect the “headerbar” item then click OK to close the undefined height prompt.

This will make the item fit the text with very little space top and bottom, so padding needs to be used to add space between the lettering and the edge of the item.

4. Select the “headerbar” item, click on the Padding popup in the Inspector and choose 20px.

6. Style the text in the Inspector to suit.

7. Deselect the item and click OK to the undefined height prompt.

8. Select the item again and apply padding of 5px.

9. Repeat steps 5-8 to insert dummy text inside the “rhpanel” item and to add Padding.

10. Double-click inside the “footerbar” item and enter the words “Footer Bar” (without the quotes). Select the text, style it as Verdana 36px and center aligned.

11. Click away from the item and click OK to the undefined height prompt.

12. Select the item again and add Padding of 20px.

Your Freeway file should now look similar to the screenshot below.

Remember that you can always choose Custom so you can use different padding values to the top, bottom, left or right. It is worth noting that you can use Margin to add space but not colour fill between items—and, again, you can apply different values by using Custom.

5. Double-click inside the “lhpanel” item and enter some dummy text.
Now when you preview in a browser you’ll see that because you have undefined heights on the text panels, they will always expand to fit the content. Also, because the browserbackground item has an undefined height, if the items inside that item expand, then it will also expand in height to suit.

The best way to test the page to see this working is to view them in Safari or Firefox, making sure “Zoom text only” is checked in the View menu, then typing Command-+ to enlarge the default type size of a browser (typing command and minus/hyphen will reduce the default size again and typing command and zero will reset the default size again). One reason for using this method to check your pages is to see what will happen if a browser’s default font size increases (which it will often do, especially in Internet Explorer for PC).

This completes this very brief and basic introduction to box-model (inline CSS) layout in Freeway.

**Further options when working in box-model**

By experimenting you will find that sometimes you might want to use extra HTML items in the layout as “spacers” between the header and page content, etc., and sometimes you will need to “nest” HTML items inside others by one or more levels of parent/child relationship to get the layout to work the way you want.

If you want a rule between different items, you can simply set up a Custom border with just a rule on one edge (the top or the bottom) of an item and use a Margin or Padding value on the neighbouring item to give space between them - all of this you will need to work out for yourself as you become more familiar with the box-model method.

Note that you can also just draw items on top of an HTML item so you can move items around freely within the parent item (rather than using Insert>HTML item or Insert>Graphic item all the time) — but doing this will mean that you can’t use an undefined height on the item as the child items are not inserted using the true “inline” method.

To make Rollovers and stacks of Target images you will need to use the first rollover or target image graphic on the page, apply the Action and then choose the other elements for the Rollover/Target stack by clicking on the triangle on the appropriate column header bar in the Actions palette by choosing Select.